<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.douglascountyherald.com/wp-content/cache/borlabs_cache/1/js/9aeb4903db9b871f0439c2d822d99cd5b13c96a4_https.js" as="script">
<link rel="preload" href="https://www.douglascountyherald.com/wp-content/cache/borlabs_cache/1/css/81cbe343837474da27dff2f5e83ffef78c3095a3_https.css" as="style">
<link rel="stylesheet" href="https://www.douglascountyherald.com/wp-content/cache/borlabs_cache/1/css/81cbe343837474da27dff2f5e83ffef78c3095a3_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.douglascountyherald.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.douglascountyherald.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.douglascountyherald.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Circuit Court December 14, 2020 &#8211; Douglas County Herald</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel="alternate" type="application/rss+xml" title="Douglas County Herald &raquo; Feed" href="https://www.douglascountyherald.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Douglas County Herald &raquo; Comments Feed" href="https://www.douglascountyherald.com/comments/feed/" /> <meta property="og:title" content="Circuit Court December 14, 2020"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.douglascountyherald.com/2020/12/17/circuit-court-december-14-2020/"/><meta property="og:site_name" content="Douglas County Herald"/><meta property="og:image" content="https://www.douglascountyherald.com/wp-content/uploads/2020/09/gavel-e1544032618149.jpg"/>                    <style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.douglascountyherald.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                  <link rel='https://api.w.org/' href='https://www.douglascountyherald.com/wp-json/' /> <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.douglascountyherald.com/xmlrpc.php?rsd" /> <link rel='prev' title='Filing Open For April Elections' href='https://www.douglascountyherald.com/2020/12/17/filing-open-for-april-elections/' /> <link rel='next' title='Storm Grounds Unusual Plane Overnight' href='https://www.douglascountyherald.com/2020/12/17/storm-grounds-unusual-plane-overnight/' /> <link rel="canonical" href="https://www.douglascountyherald.com/2020/12/17/circuit-court-december-14-2020/" /> <link rel='shortlink' href='https://www.douglascountyherald.com/?p=71714' /> <link rel="alternate" type="application/json+oembed" href="https://www.douglascountyherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.douglascountyherald.com%2F2020%2F12%2F17%2Fcircuit-court-december-14-2020%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.douglascountyherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.douglascountyherald.com%2F2020%2F12%2F17%2Fcircuit-court-december-14-2020%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>   <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4'></script><script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=4b659158cc04550866c406109c0b4873'></script><script type="text/javascript" src="https://www.douglascountyherald.com/wp-content/cache/borlabs_cache/1/js/9aeb4903db9b871f0439c2d822d99cd5b13c96a4_https.js"></script></head> <body class="post-template-default single single-post postid-71714 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-preset-color01 fl-fixed-width" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"><div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-top-bar-menu" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-285"><a target="_blank" href="https://2537.newstogo.us/editionviewer/default.aspx?Publication=4ec1464c-13b6-4ff8-aa7b-25bebb644598">E-Edition</a></li> <li id="menu-item-286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-286"><a target="_blank" href="https://2537.newstogo.us/editionviewer/default.aspx?Publication=4ec1464c-13b6-4ff8-aa7b-25bebb644598&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-287"><a target="_blank" href="https://2537.newstogo.us/editionviewer/default.aspx?Publication=4ec1464c-13b6-4ff8-aa7b-25bebb644598&#038;view=archives">Recent Issues</a></li> <li id="menu-item-70841" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70841"><a target="_blank" href="https://douglascountyherald.newspapers.com/">Archives</a></li> </ul><div class="fl-social-icons"><a href="https://www.facebook.com/docoherald/" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-facebook fl-icon-facebook-regular"></a><a href="/cdn-cgi/l/email-protection#98f1f6fef7d8fcf7edfff4f9ebfbf7edf6ece1f0fdeaf9f4fcb6fbf7f5" class="fl-icon fl-icon-color-mono fl-icon-email fl-icon-email-regular"></a></div></div> </div> </div> </div></div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.douglascountyherald.com" itemprop="url"><img class="fl-logo-img" itemscope itemtype="http://schema.org/ImageObject" src="https://www.douglascountyherald.com/wp-content/uploads/2020/10/2537.png" data-retina="" alt="Douglas County Herald" /><meta itemprop="name" content="Douglas County Herald" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-65608" class="widget widget-webads-weather"> <a id="webads-weather-65608-link" href="https://www.douglascountyherald.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-65608-temperature" class="temperature"></span> <i id="webads-weather-65608-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-65608-location" class="location"></span> <span id="webads-weather-65608-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form method="get" role="search" action="https://www.douglascountyherald.com" title="Type and press Enter to search."> <input type="text" class="fl-search-input" name="s" class="form-control" value="Search" onfocus="if (this.value == 'Search') { this.value = ''; }" onblur="if (this.value == '') this.value='Search';"> </form></div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076"><a href="https://www.douglascountyherald.com/">Home</a></li> <li id="menu-item-71021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-71021"><a href="#">News</a> <ul class="sub-menu"> <li id="menu-item-70807" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70807"><a href="https://www.douglascountyherald.com/category/city-of-ava/">City of Ava</a></li> <li id="menu-item-70812" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-70812"><a href="https://www.douglascountyherald.com/category/douglas-county/">Douglas County</a></li> <li id="menu-item-70817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70817"><a href="https://www.douglascountyherald.com/category/school-news/">School News</a></li> <li id="menu-item-70844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70844"><a href="https://www.douglascountyherald.com/category/school-news/sports-school-news/">School Sports</a></li> </ul> </li> <li id="menu-item-71168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71168"><a href="https://www.douglascountyherald.com/videos/">Videos</a></li> <li id="menu-item-70832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70832"><a href="https://www.douglascountyherald.com/category/editorial-opinion/">Editorial/Opinion</a> <ul class="sub-menu"> <li id="menu-item-70833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70833"><a href="https://www.douglascountyherald.com/category/letter-to-the-editor/">Letter To The Editor</a></li> <li id="menu-item-70826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70826"><a href="https://www.douglascountyherald.com/category/the-snoop/">The Snoop</a></li> </ul> </li> <li id="menu-item-70834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-70834"><a href="#">Columns</a> <ul class="sub-menu"> <li id="menu-item-70830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70830"><a href="https://www.douglascountyherald.com/category/timber-jones/">Timber Jones</a></li> <li id="menu-item-70827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70827"><a href="https://www.douglascountyherald.com/category/notes-from-hunter-creek/">Notes from Hunter Creek</a></li> <li id="menu-item-70831" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70831"><a href="https://www.douglascountyherald.com/category/what-about-this/">What About This?</a></li> <li id="menu-item-70845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70845"><a href="https://www.douglascountyherald.com/category/barbara-sisney-daniel/">Barbara Sisney Daniel</a></li> </ul> </li> <li id="menu-item-292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-292"><a href="https://www.douglascountyherald.com/obituaries/">Obituaries</a></li> <li id="menu-item-70805" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70805"><a href="https://www.douglascountyherald.com/contact-us/">Contact Us</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.douglascountyherald.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-71714 post type-post status-publish format-standard has-post-thumbnail hentry category-douglas-county category-featured-story" id="fl-post-71714" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Circuit Court December 14, 2020 </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-date" itemprop="datePublished" datetime="2020-12-17">December 17, 2020</span></div><meta itemprop="image" content="https://www.douglascountyherald.com/wp-content/uploads/2020/09/gavel-e1544032618149.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-thumb"><img width="300" height="195" src="https://www.douglascountyherald.com/wp-content/uploads/2020/09/gavel-e1544032618149.jpg" class="attachment-large size-large wp-post-image" alt="" itemprop="image" /></div> <div class="fl-post-content clearfix" itemprop="text"> <p>During a Circuit Court docket with Judge Raymond Gross on December 14, 2020, the following defendant was sentenced to the Department of Corrections: <span class="Apple-converted-space"> </span></p> <p>Jonathon Snelson, 20, Ava, was sentenced to 120 days in prison after admitting to violating his probation. Snelson was ordered to complete Institutional Treatment while in the Department of Corrections. The original offense occurred in September of 2017 and was investigated by the Ava Police Department. <span class="Apple-converted-space"> </span></p> <p>Source: Douglas County Prosecuting Attorney’s Office</p> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.douglascountyherald.com/category/douglas-county/" rel="category tag">Douglas County</a>, <a href="https://www.douglascountyherald.com/category/featured-story/" rel="category tag">Featured Story</a></div></div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.douglascountyherald.com/2020/12/17/filing-open-for-april-elections/" rel="bookmark" title="Filing Open For April Elections"> <img width="275" height="183" src="https://www.douglascountyherald.com/wp-content/uploads/2020/09/vote.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.douglascountyherald.com/2020/12/17/filing-open-for-april-elections/" rel="bookmark" title="Filing Open For April Elections">Filing Open For April Elections</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> December 17, 2020 </span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.douglascountyherald.com/2020/12/17/christmas-closings/" rel="bookmark" title="Christmas Closings"> <img width="200" height="187" src="https://www.douglascountyherald.com/wp-content/uploads/2020/09/Screen-Shot-2018-11-14-at-11.58.50-AM-e1544657232317.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.douglascountyherald.com/2020/12/17/christmas-closings/" rel="bookmark" title="Christmas Closings">Christmas Closings</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> December 17, 2020 </span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.douglascountyherald.com/2020/12/10/circuit-law-day-december-8-2020/" rel="bookmark" title="Circuit Law Day December 8, 2020"> <img width="300" height="195" src="https://www.douglascountyherald.com/wp-content/uploads/2020/09/gavel-e1544032618149-300x195.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.douglascountyherald.com/2020/12/10/circuit-law-day-december-8-2020/" rel="bookmark" title="Circuit Law Day December 8, 2020">Circuit Law Day December 8, 2020</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> December 10, 2020 </span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.douglascountyherald.com/2020/12/10/hwy-5-wreck-injures-two/" rel="bookmark" title="Hwy 5 Wreck Injures Two"> <img width="300" height="300" src="https://www.douglascountyherald.com/wp-content/uploads/2020/12/image0-1-300x300.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.douglascountyherald.com/2020/12/10/hwy-5-wreck-injures-two/" rel="bookmark" title="Hwy 5 Wreck Injures Two">Hwy 5 Wreck Injures Two</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> December 10, 2020 </span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.douglascountyherald.com/2020/12/03/the-season-for-giving/" rel="bookmark" title="The Season for Giving"> <img width="300" height="300" src="https://www.douglascountyherald.com/wp-content/uploads/2020/12/Food-drive-300x300.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.douglascountyherald.com/2020/12/03/the-season-for-giving/" rel="bookmark" title="The Season for Giving">The Season for Giving</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> December 3, 2020 </span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"> <aside id="webads_oev1_widget-3" class="fl-widget widget_webads_oev1_widget"><h4 class="fl-widget-title">Online Edition</h4>  <div class="fl-photo fl-photo-align-center" itemscope="" itemtype="http://schema.org/ImageObject"> <div class="fl-photo-content"> <a id="webads-online-edition-927" href="https://www.google.com" target="_blank" /></a> </div> </div> </aside><aside id="5e3a2158eaeca-3" class="fl-widget 5e3a2158eaeca"><!-- Error, Ad (3) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="5e3a2158eaeca-2" class="fl-widget 5e3a2158eaeca"><!-- Error, Ad (4) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="webads_facebook_widget-2" class="fl-widget widget_webads_facebook_widget"><h4 class="fl-widget-title">Like Us On Facebook</h4> <div id="fb-root"></div>  <div class="fb-page" data-href="https://www.facebook.com/docoherald/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div> </aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-12 col-md-12"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Douglas County Herald</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="https://www.douglascountyherald.com/">Home</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.douglascountyherald.com/contact-us/">Contact Us</a></li> <li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a target="_blank" href="https://2537.newstogo.us/editionviewer/default.aspx?Publication=4ec1464c-13b6-4ff8-aa7b-25bebb644598">E-Edition</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" href="https://2537.newstogo.us/editionviewer/default.aspx?Publication=4ec1464c-13b6-4ff8-aa7b-25bebb644598&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-232"><a target="_blank" href="https://2537.newstogo.us/editionviewer/default.aspx?Publication=4ec1464c-13b6-4ff8-aa7b-25bebb644598&#038;view=archives">Recent Issues</a></li> <li id="menu-item-70840" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70840"><a target="_blank" href="https://douglascountyherald.newspapers.com/">Archives</a></li> </ul></div></aside></div> </div> </div> </div><div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>           
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script></body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 2.14221191 sec
Time to load cache: 2.14796901
Cache file created on: 2020-12-17T14:00:25+00:00
Current time: 2020-12-17T14:00:25+00:00
-->